welcome to my cool homepage!

i HATE git

  find all authors: git shortlog -sne
  how to fix git: get reset --hard, rm -rf dir; git clone github.com/dir
  

Mac OS X 10.whatever pro tips:

  how to reboot your mac without typing in your password: fdesetup authrestart
  for making your screenshots suck less: defaults write com.apple.screencapture disable-shadow -bool true
  for being able to see things clearly: defaults write NSGlobalDomain AppleEnableMenuBarTransparency -bool false
  for use instead of dd: segedit --extract
  for when app store messes up: softwareupdate -l && softwareupdate -ia
  for when app store messes up: defaults write com.apple.appstore ShowDebugMenu -bool true
  for when you want to disable spotlight: sudo mdutil -a -i off
  for when you dont want to ruin everyone elses network share view: defaults write com.apple.desktopservices DSDontWriteNetworkStores true
  

How to get linux from osx

  diskutil umountDisk /dev/disk8
  hdiutil convert ubuntu.iso -format UDRW -o ubuntu.iso.img.dmg
  dd if=ubuntu.iso.img.dmg.dmg of=/dev/disk8 bs=1m
  diskutil eject /dev/disk8
  

Command pro tips:

  parallel
  watch -n 1 cmd
  ack-grep
  

lldb stuff:

  settings set target.x86-disassembly-flavor intel
  
:wq